Google Chrome y los acentos en Linux Mint (Ubuntu y derivadas). IBus en Gtk+ y Qt

Hace algunas semanas me percaté que nuestro navegador favorito, Google Chrome, no reconocía los acentos en Linux Mint, distribución basada en Ubuntu, por lo que esta última es la causante del problema. A la hora de escribirlos, y pulsar la tecla del acento, no se asociaba a la tecla que pulsabas posteriormente, un problema de codificación.

En un principio pensé que el problema derivaba de la configuración del lenguaje del teclado, pero me sorprendió ver que en cualquier editor de texto local no me ocurría.

Tal vez puedas pensar que para búsquedas en Google, no es un problema grave, pero si eres asiduo a utilizar la suite ofimática en la nube Google Drive para realizar documentos formales, es imposible trabajar.

IBus y los acentos

IBus es el método de entrada que interpreta lo que escribimos y lo traduce en los caracteres que queremos ver, es decir, cuando tecleamos ‘a lo que realmente queremos ver es á. IBus es la aplicación que se encarga de realizar esta operación en Ubuntu desde la versión 9.10 ya que en versiones anteriores utilizaba SCIM.

Ahora bien, llegados a este punto nos encontramos que para relacionarse con IBUS los dos grandes sistemas para crear interfaces gráficas como son Gtk+y Qt necesitan de sus particulares bibliotecas como son ibus-gtk y su homóloga ibus-qtk, para Gtk+ y Qt respectivamente.

Solución

Google Chrome utiliza Qt, por lo que basta con instalar el paquete correspondiente para solucionarlo:

 

Más información:

IBus

Ubuntu

Solución: error while loading shared libraries: libudev.so.0: cannot open shared object file:

Al instalar algunos programas en Linux, podemos encontramos con la sorpresa de que tras la instalación, la aplicación no arranca. Un primer paso para elaborar un diagnóstico es, a través de un terminal lanzar el ejecutable y ver si devuelve algún tipo de error.

Esto es lo que me pasó al instalar Isoplex (y algunos usuarios también lo han reportado con la instalación de Popcorn Time). Tras la instalación, no me arrancaba y probé por terminal, el error que me devolvía era:

Para resolver el problema, simplemente tienes que crear un enlace simbólico con el siguiente comando:

¡Y listo!, ya podéis arrancar la aplicación sin problemas.

¡Saludos!